Hello !
Northern Virginia Jeepers Association
May 25, 2018, 05:27:47 PM

Pages: [1] Go Down
  Print  
Author Topic: Possessed Jeep  (Read 459 times)
0 Members and 1 Guest are viewing this topic.
total2010
Offline
Forum User
Posts: 164
« on: February 10, 2018, 07:58:57 PM »

My 08 JKU has been possessed. Long story short, it was the TIPM which I did replace. Symptoms were (Wipers and washer fluid going crazy, horn blowing non-stop, Car running with no key in ignition, doors locking and unlocking rapidly with no control & headlights turning on and off) The Jeep went fine for about 10 months after the TIPM was replaced and now the same issue is back again  Crying I'm wondering if there's an issue with the wiring somewhere. Specially that I recently added some lights and LEDs a year ago. Last time the TIPM did the trick and there were no further issues. Now I'm worried that it'll happen again on the highway or somewhere where I can't control it. are there any common wires that go loose in the JK?? any loose grounds somewhere? The Jeep could shut off by itself which is very dangerous. Anybody knows a good shop that could look over the factory wiring for a good price? or any known wires that tend to go bad/break in the JKS ??

Logged
sirjames186
Offline
Club Secretary
*
Posts: 2245
05 LJ
« Reply #1 on: February 10, 2018, 08:44:06 PM »

Did you ever put that tri-link in and do the 4wd conversion?

Seriously. Issues could come from that.

Logged

"I'm no longer ashamed to wheel with you." - Jeremy
dave2002ti
Offline
Member 2018
*
Posts: 870
« Reply #2 on: February 11, 2018, 03:19:27 PM »

TIPM is/was a recall item for certain model year WK2 Jeep Grand Cherokees.  Lindsay screwed mine up doing the recall. It was fixed by another dealer since I specifically told them not to do that recall repair and they did it anyhow.
One of the many reasons I never went back to Lindsay and never recommend them.

Dave Apker


Logged
zuke
Offline
Forum User
Posts: 1180
« Reply #3 on: February 11, 2018, 05:54:26 PM »

Dammit, Again? Double check the main connections to the TIPM again... Did you put Dielectric on everything when you replaced it? Might just be some fresh corrosion on some of the connections, I hope this is something simple like that...

What kind of ranges are you typically seeing on the guage? The alternator isn't overcharging, is it?

Logged

John
2017 BU Trailhawk
2015 JK Unlimited Sahara
2008 JK Unlimited
2006 TJ Rubicon
1999 TJ SE
1990 SJ Waggy
1989 XJ Cherocar
total2010
Offline
Forum User
Posts: 164
« Reply #4 on: February 11, 2018, 07:24:20 PM »

Did you ever put that tri-link in and do the 4wd conversion?

Seriously. Issues could come from that.

Oh, the first time it happened was way before the conversion.  Confused  But yeah, I did do the conversion but ended up sticking with a stock Dana 30 front and kept my rear. Project 100% done and functional.

Logged
total2010
Offline
Forum User
Posts: 164
« Reply #5 on: February 11, 2018, 07:25:38 PM »

TIPM is/was a recall item for certain model year WK2 Jeep Grand Cherokees.  Lindsay screwed mine up doing the recall. It was fixed by another dealer since I specifically told them not to do that recall repair and they did it anyhow.
One of the many reasons I never went back to Lindsay and never recommend them.

Dave Apker

NEVER go to Lindsay, they're the worst. Unfortuantely, mine doesn't have a recall  Crying Jeep screwed me on that one

Logged
total2010
Offline
Forum User
Posts: 164
« Reply #6 on: February 11, 2018, 07:33:45 PM »

Dammit, Again? Double check the main connections to the TIPM again... Did you put Dielectric on everything when you replaced it? Might just be some fresh corrosion on some of the connections, I hope this is something simple like that...

What kind of ranges are you typically seeing on the guage? The alternator isn't overcharging, is it?

Yessir!! a little shorter than 10months and the same thing is happening again. I did check the main connections, everything was nice and tight. I took out the TIPM and sent it back for a replacement one...Hopefully that does it this time -_- I'm just curious, anyone had this problem before?

Logged
zuke
Offline
Forum User
Posts: 1180
« Reply #7 on: February 12, 2018, 02:27:40 AM »

I've replaced the TIPM's on 2 chrysler vehicles I've owned, One JK (2008) and One Ram Pickup (2005)... Both at less than 80k miles... But past warranty, Didn't ever have to replace them again though...

Logged

John
2017 BU Trailhawk
2015 JK Unlimited Sahara
2008 JK Unlimited
2006 TJ Rubicon
1999 TJ SE
1990 SJ Waggy
1989 XJ Cherocar
schreiberaj
Online
Forum User
Posts: 209
« Reply #8 on: February 12, 2018, 07:48:49 AM »

Sell it and get a TJ

Logged
Pages: [1] Go Up
  Print  
 
Jump to:  

Powered by EzPortal
Powered by SMF 1.1.21 | SMF © 2015, Simple Machines | Theme Design by: Xarcell